NestHD

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Introduction

NestHD ››

Introduction

Delft3D-FLOW models require hydrodynamic and transport boundary conditions. In case the boundary conditions of a model are generated by a larger (overall) model we speak of a nested model. Nesting in Delft3D-FLOW is executed in three steps, using two separate utilities and the Delft3D-FLOW program. This manual describes the steps to generate boundary conditions for a nested Delft3D-FLOW model.

In principle, the nested boundary conditions are generated by bi-linear interpolation of computational results at monitoring stations of the overall model.

The procedure to generate nested boundary conditions consists of 3 steps:

    1. Using the tool NESTHD1 a list of monitoring stations in the overall model, needed for the interpolation, can be generated. In addition to this, the program generates the nesting administration, i.e. the link between the boundary support points in the nested model and the monitoring stations in the overall model.
    2. Run the overall model with the list of monitoring stations generated by NESTHD1.
    3. The actual boundary conditions for the nested model are generated by NESTHD2 using the history file of the overall model and the nest administration.

Restrictions:

At present, the nesting programs have the following limitations:

    1. Both model grids must be supplied in a grid file and must be defined in the same co-ordinate system.
    2. Hydrodynamic boundary conditions are of the water level or (perpendicular) velocity type. Discharge and Riemann boundary conditions are not implemented yet.
    3. The boundary definition of the nested model has to be supplied as an attribute file.
    4. Temporary dry points in the overall model are not taken into account in the nesting programs.
    5. For a nested 3D model the number and the thickness of the layers must be identical to the overall model.
    6. The generated boundary conditions are written to a time-series file. This implies that the reference date of a simulation with the nested model must be identical to the reference date of the overall model simulation used to generate the boundary conditions.

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


How to use Nesthd1

NestHD ››

How to use NESTHD1

NESTHD1 is part of the Delft3D-FLOW tools. To access NESTHD1, first set the current directory to the directory where you have stored the required input files. Then:

1. Select Tools in the Hydrodynamics selection window, see Figure F-1:

Figure F-1 Hydrodynamics selection window with the Tools option

Next Figure F-2 is displayed.

Figure F-2: Additional tools window with the NESTHD1 and NESTHD2 options

To start NESTHD1:

1. Select Nesting (1).

You are asked to supply the following information, see also Figure F-3:

  1. The filename of the grid file of the overall model.
  2. The filename of the enclosure file of the overall model.
  3. The filename of the grid file of the nested model.
  4. The filename of the enclosure file of the nested model.
  5. The filename of the boundary definition file of the nested model. This file must fulfil the conventions as specified in the Delft3D-FLOW manual.
  6. The name of the file containing the nest administration. An example of this file as used for nesting of the Stonecutters Island model in the Pearl Estuary model is given in Chapter example.
  7. The name of the file containing the position of the monitoring stations in the overall model. This file can be used directly in a Delft3D-FLOW simulation with the overall model.

Figure F-3 Specification of input and output files for NESTHD1

After running NESTHD1 a simulation with the overall model should be executed using the monitoring stations as generated by NESTHD1.

Created with the Personal Edition of HelpNDoc: Easily create Help documents


How to use Nesthd2

NestHD ››

How to use NESTHD2

NESTHD2 is part of the Delft3D-FLOW tools. To access NESTHD2, first set the current directory to the directory where you have stored the required input files. Then enter the Tools menu, see Figure F-1.

To start NESTHD2, see Figure F-2:

    1. Select Nesting (2).

You are asked to supply the following information, see also Figure F-4:

  1. The boundary definition file of the detailed model.
  2. The filename of the administration file as generated by NESTHD1.
  3. The extension (runid) of the history file of the overall model.
  4. The filename of the file with hydrodynamic boundary conditions. This file can be used directly in a simulation with the nested model.
  5. The filename of the file with transport boundary conditions. This file can be used directly in a simulation with the nested model.
  6. The filename of the diagnostic file. You are advised to inspect this file.
  7. An optional (constant) adjustment of the boundary values at water level boundaries. This can be used if both models have a different vertical reference level.
  8. In case of a 3-dimensional overall model and a nested model with velocity boundaries you are asked if you want to generate depth-averaged or 3-dimensional velocity boundary conditions.
  9. For each of the constituents in the overall model you are asked:
    • If you want to generate boundary conditions for this constituent,
    • How much you want to add to the computed overall model value for this constituent,
    • The maximum value for this constituent,
    • The minimum value for this constituent
  1. The type of transport profile. You can chose between a uniform profile for depth-averaged computations with the nested model, a linear profile using only the computed boundary values at the surface and the bed and a 3D-profile resulting in boundary values for all computational layers of the nested model.

Figure F-4 Specification of input and output files for NESTHD2

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Example

NestHD ››

Example

This example describes the nesting of the Siu Lam model in the Pearl Estuary model. The grid layout of both models is given in Figure F-5:

Figure F-5 Overview grids overall and nested models

The input and output files of this example are stored in the FLOW Tutorial directory: <tutorial\flow\nesthd>.

Using NESTHD1 the monitoring stations file and the administration file are generated. The contents of these files are shown below:

Part of monitoring stations file <nesthd1.obs>:

(M,N) = ( 27, 35) 27 35

(M,N) = ( 27, 36) 27 36

(M,N) = ( 27, 41) 27 41

(M,N) = ( 27, 42) 27 42

(M,N) = ( 28, 35) 28 35

(M,N) = ( 28, 36) 28 36

. . . . .

. . . . .

(M,N) = ( 29, 35) 29 35

(M,N) = ( 29, 36) 29 36

(M,N) = ( 29, 41) 29 41

(M,N) = ( 29, 42) 29 42

(M,N) = ( 31, 30) 31 30

(M,N) = ( 31, 31) 31 31

These monitoring stations have been included (added) to the already existing <*.obs> file of the Pearl model. In this tutorial <hkcrssl1.obs>.

Part of the administration file <nesthd1.adm>:

*

* WL | Delft Hydraulics, Delft3D-NESTHD1 Version 1.52.00, Sep 21 2004

*

* Run date :2005/05/11 22:36:06

*

* Name grid file overall model : overall.grd

* Name enclosure file overall model : overall.enc

*

* Name grid file detailed model : nested.grd

* Name enclosure file detailed model : nested.enc

* Name bnd. definition file detailed model : nested.bnd

*

* Name nest administration file : nesthd1.adm

* Name FLOW observation file : nesthd1.obs

Nest administration for water level support point (M,N) = ( 49, 1)

28 45 0.5107

29 45 0.1822

28 46 0.2264

29 46 0.0808

Nest administration for water level support point (M,N) = ( 56, 1)

28 43 0.1496

29 43 0.0271

28 44 0.6972

29 44 0.1261

. . . .

. . . .

Nest administration for water level support point (M,N) = ( 53, 74)

47 45 0.8564

48 45 0.1436

0 0 0.0000

0 0 0.0000

Nest administration for water level support point (M,N) = ( 57, 74)

47 44 0.3268

48 44 0.0965

47 45 0.4453

48 45 0.1315

Nest administration for velocity support point (M,N) = ( 49, 1) Angle = 20.409

28 45 0.3888

29 45 0.3216

28 46 0.1585

29 46 0.1311

Nest administration for velocity support point (M,N) = ( 56, 1) Angle = 20.409

28 43 0.1368

29 43 0.0773

28 44 0.5022

29 44 0.2838

. . . .

. . . .

Nest administration for velocity support point (M,N) = ( 53, 74) Angle = 122.632

47 45 0.9973

48 45 0.0027

0 0 0.0000

0 0 0.0000

Nest administration for velocity support point (M,N) = ( 57, 74) Angle = 122.632

47 44 0.4247

48 44 0.0355

47 45 0.4982

48 45 0.0416

Remarks:

  • When you run the NESTHD1 tool, the location of the nested boundary should be final.
  • The type of data (water level or velocity) need not be final. That’s why NESTHD1 generates the administration for both.
  • The type of data should also be final. NESTHD1 only generates the administration for time-series.

The first lines, starting with an asterisk, are comment lines. These are followed by several blocks of 5 lines containing the information on nesting of water level and transport boundaries. The first of these lines gives the indices of the boundary support point. This line is followed by 4 lines containing the indices of the surrounding overall model monitoring stations and the relative weights of these stations. The information on nesting of water levels and transport is followed by information on nesting of velocities.

To adjust the nesting, for instance to avoid the use of a monitoring station that dries during the computation, the administration file should be adjusted by hand.

Before running NESTHD2, first the overall model should be run, using the <o2d.mdf> file.

Remark:

  • It is a good modelling practice to re-generate the bathymetry in the overall model using the detailed bathymetry of the nested model.

If you Verify this scenario the following warning will be generated:

*** WARNING Station (M,N) = ( 28, 46) lies outside the computational domain

This means that this required nesting stations lies on a dry point. If you check the administration file, you will see that every boundary support point has at least 2 overall nest stations. Ignoring the nest station which lies on a dry point would result in the worst case that the nesting information only comes from 1 overall station. (If you check the administration file carefully, you will find out that the mentioned station is always part of a set of 4.)

Using the administration file <nesthd1.adm> and the history file <trih-o2d.*> of the Pearl Estuary model, the boundary conditions for the Siu Lam model have been generated by running NESTHD2.

The result files are the hydrodynamic flow boundary conditions <siulam2d.bct> and the transport boundary conditions <siulam2d.bcc>.

The diagnostic file contains the following warning:

*** Warning: Nest station ( 28, 46) not on history file. Weights reset

This station, as noted before, lies on a dry point. NESTHD2 then resets weights.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease